I Found The Problem

Those of you running WordPress might find an enforced upgrade to 1.5.2 in your near future, if you’re not there already. There is exploitable code in earlier versions of WordPress in the XMLRPC section. I’m upgrading some sites, and a couple sites on very old code have been temporarily offlined.

The WordPress people say that the entire 1.5 line is safe, but I’ve seen some stuff that suggests otherwise. And while I inherently trust the WordPress people for all things webloggy, I’m not going to take any chances. Anyway, they’d want you to upgrade in any case. 1.5.2 is pretty snazzy.